Popper Coffee Roaster Has No Heat?

The fix could be super simple: A connector may have come loose.

In the last month we have seen a few Popper roasters where they start blowing cold – no heat. The function seems fine, the fan blows strong, but there is no heat.

This was something new, and when we looked at the first unit, the fix was so simple. One of the connectors that goes to the thermal switch on the side of the roast chamber had simply come off.

I am not sure why this would happen, but in each case the fix took less than 5 minutes. Most people might be interested in doing this themselves so here is what is needed:

  1. Get a small phillips head driver, number 0 or 1.
  2. Pop off the 4 rubber feet on the bottom of popper. See Image Below
  3. Loosen the screws under the rubber feet (I leave them very slightly in, as it makes reassembly faster)
  4. Remove the 2 screws on the bottom of popper along the front .See Image Below
  5. Ease the Popper shell off the base – there is a ribbon cable attached but you can wiggle the shell off without undoing it. Don’t yank on it!
  6. You will see the 2 wires going into the thermal switch on the side of the roast chamber, through the opening in the foam insulation shield. See Image Below
  7. Is one off? Loose? Slide back the silicone cover and reattach the connectors. Crimp them on securely with pliers.
  8. Note that sometimes the silicone boot is discolored or heat damaged, These aren’t really critical to the function, so I usually remove them altogether. See Image Below
  9. Reverse the steps to reassemble and you are done!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Reddit
Facebook
Twitter
LinkedIn
Email